From 0f33fa5f11c38a6a869e97c337076ef388811867 Mon Sep 17 00:00:00 2001 From: Sjors Gielen Date: Thu, 14 Nov 2024 12:00:52 +0100 Subject: [PATCH] docs: amend k8s and Ceph minimum versions in the 1.15 upgrade guides. Fixes #14998 Signed-off-by: Sjors Gielen --- Documentation/Upgrade/ceph-upgrade.md | 1 + Documentation/Upgrade/rook-upgrade.md | 3 +++ 2 files changed, 4 insertions(+) diff --git a/Documentation/Upgrade/ceph-upgrade.md b/Documentation/Upgrade/ceph-upgrade.md index 0ea0e3a51..7e4128e3f 100644 --- a/Documentation/Upgrade/ceph-upgrade.md +++ b/Documentation/Upgrade/ceph-upgrade.md @@ -26,6 +26,7 @@ until all the daemons have been updated. Rook v1.15 supports the following Ceph versions: +* Ceph Squid v19.2.0 or newer * Ceph Reef v18.2.0 or newer * Ceph Quincy v17.2.0 or newer diff --git a/Documentation/Upgrade/rook-upgrade.md b/Documentation/Upgrade/rook-upgrade.md index d3749b3bf..2521e4fcb 100644 --- a/Documentation/Upgrade/rook-upgrade.md +++ b/Documentation/Upgrade/rook-upgrade.md @@ -51,6 +51,9 @@ those releases. ## Breaking changes in v1.15 +* The minimum supported version of Kubernetes is v1.26. + Upgrade to Kubernetes v1.26 or higher before upgrading Rook. + * Rook has deprecated CSI network "holder" pods. If there are pods named `csi-*plugin-holder-*` in the Rook operator namespace, see the [detailed documentation](../CRDs/Cluster/network-providers.md#holder-pod-deprecation)